Getagged: Office 2013

Apps for Office – QR4Office – QR-Codes erzeugen

Im Register Einfügen befinden sich ab Office 2013 in Word, Excel und PowerPoint die Apps für Office. Hier lassen sich kostenlose und kostenpflichtige Apps im Microsoft Store herunterladen, welche sich in die Office-Dokumente integrieren.

Seit kurzer Zeit gibt es auch eine App zur Erstellung von QR-Codes. Michael Zlatkovsky hat die App QR4Office für Office 2013 programmiert und kostenlos zur Verfügung gestellt. Mir persönlich spart es deshalb Zeit, da ich nicht in andere Programme oder auf Webseiten wechseln muss, um mal eben einen QR-Code zu erzeugen. Michael hat erwähnt, dass es in Kürze auch einige Anpassungen und Neuerungen geben wird, so dass die Screenshots hier eventuell abweichen.

QR4_1

Ich nutze QR-Codes zum Beispiel in Schulungsunterlagen. Passend zum Thema gibt es dann vielleicht ein Video. Nun die Frage? Schreibe ich einen Link? Oder soll jemand auf ein Bildchen klicken? Oder soll jemand einen QR-Code abscannen und das Video direkt auf einem mobilen Device (Tablet, Smartphone) sehen?

Warum nicht alles drei auf einmal?

QR_2

Über QR-Codes können auch andere Informationen, wie zum Beispiel Telefonnummern oder E-Mail-Adressen mitgeteilt werden.

QR_5

Weisen die QR-Codes größere Fehlertoleranzen aus, können auch noch kleine Grafiken in die QR-Codes eingebettet werden. Hierfür wähle ich allerdings ein externes Grafikprogramm, in der das Logo bereits hinterlegt ist und kopiere dieses Logo in den QR-Code hinein.

Hier geht es zum YouTube-Video:

Excel 2013 – FORMELTEXT, ISTFORMEL und WENNNV

Identifizieren, ob eine Zelle eine Formel enthält und wie diese lautet. Zwei in Excel 2013 eingeführte Funktionen unterstützen Sie dabei.

=FORMELTEXT(Zellbezug)
=ISTFORMEL(Zellbezug)

Mit der Funktion =FORMELTEXT(A1) lässt sich die Formel der Zelle A1 anzeigen.
Steht dort allerdings keine Formel, zeigt das Formelergebnis #NV an.

Mit der Funktion =ISTFORMEL(A1) kann eine Zelle dahin gehend überprüft werden, ob überhaupt eine Formel in der Zelle A1 ist. Das Ergebnis lautet hier WAHR oder FALSCH.

Folglich kann mit =WENN(ISTFORMEL(A1);FORMELTEXT(A1);A1) geprüft werden, ob sich eine Formel in einer Zelle befindet. Falls WAHR, wird diese angezeigt, Falls FALSCH, wird der Zellwert angezeigt.

E356
Statt =WENN(ISTFORMEL(A1);FORMELTEXT(A1);A1) kann aber auch die ebenfalls neue Funktion =WENNNV(FORMELTEXT(A1);A1) genutzt werden. Ähnlich der mit Excel 2010 eingeführten Funktion WENNFEHLER wird bei WENNNV geprüft, ob bei einer Formel oder Funktion der Wer #NV herauskommt. Falls nicht, wird einfach die Funktion ausgeführt. Falls doch, wird das Alternativergebnis ausgeführt.
Die Funktionen lassen sich auch dafür nutzen, Zellen mit Formeln optisch über die Bedingte Formatierung hervorzuheben. Zum Beispiel können Sie die Stellen hervorheben, wo Formeln stehen sollten aber nun manuelle Eingaben zu finden sind.

Die Funktion =ISTFORMEL(B2)=FALSCH liefert das Ergebnis FALSCH, falls sich eine Formel in Zelle B2 befindet, da hier das Ergebnis des Vergleichs gilt. Ist eine Formel in Zelle B2, kommt bei =ISTFORMEL(B2) das Ergebnis WAHR heraus und letztendlich bei =ISTFORMEL(B2)=FALSCH ein =WAHR=FALSCH, wodurch hier ein FALSCH resultiert. Entsprechend bei einer Formel in Zelle B2 ein WAHR.

Das WAHR als Formelergebnis ist bei der Bedingten Formatierung notwendig, um die Formatierung auszulösen.

E356-1

Vorab wurde der Bereich B2:B5 markiert und über das Register START in der Gruppe FORMATVORLAGEN der Schalter BEDINGTE FORMATIERUNG betätigt. Wählen Sie hier Neue Regel und anschließend den untersten Eintrag Formel zur Ermittlung der zu formatierenden Zellen verwenden. B2 ist bei der Markierung die hervorgehobene Zelle, in der auch Zelleingaben stattfinden würden. Die Zelle B2 wird stellvertretend für die drei anderen Zellen formatiert. Die jeweiligen Zellen beziehen die Formel entsprechen auf sich. Zum Beispiel =ISTFORMEL(B5)=FALSCH in Zelle B5.

Die Abbildung zeigt durch die Hervorhebung, dass in Zelle B3 keine Formel vorliegt.

Spannender wird es, wenn es mehrere Tabellenblätter gibt und dort auf die Zelle genau überprüft werden soll, ob in den einzelnen Zellen der jeweiligen Blätter dieselben Formeln vorliegen, wobei die manuellen Eingaben von Werten abweichen dürfen. Also =FORMELTEXT(Blatt1!A1)=FORMELTEXT(BLATT2!A1) bzw. =FORMELTEXT(A1)=FORMELTEXT(BLATT2!A1), wenn sich der Vergleich auf Blatt1 befindet.

Im nächsten Beitrag werde ich mehrere Monatsblätter mit einem Referenzblatt vergleichen…

Bei früheren Excel-Versionen kann man über =ZELLE.ZUORDNEN(48;Zellbezug) ermitteln, ob sich eine Formel in der Zelle befindet. Mehr dazu in Excel # 244 bei YouTube.

Hier gibt es das YouTube-Video: