Getagged: Datenüberprüfung

SVERWEIS und INDIREKT – Dynamischer Zugriff

Ich möchte einen Kunden per Dropdown auswählen und dann passend zum Kunden einen Wert aus einer separaten Kundentabelle auslesen. Die Tabellen heißen tab_Bundesländer und pro Kunde dann entsprechend tab_NRW, tab_BRA, tab_BAY und tab_HES. Der Name des Tabellenblatts ist hier unwichtig.

 

Per Dropdown wird dann ein Kunde ausgewählt. In der Datenüberprüfung wird auf die Bundesländer verwiesen. Ein neuer Eintrag in der Kundenliste wird dann automatisch auch im Dropdown aufgeführt.

 

Anschließend kann lediglich ein Projekt zum Kunden in Spalte C ausgewählt werden.

 

Per SVERWEIS muss ich nun dynamisch auf eine der beliebig vielen Tabellen zugreifen. Ich setze den Tabellennamen immer aus dem Teil „tab_“ und dem Kundennamen zusammen. Erweiterungen innerhalb der Tabellen werden automatisch mit ausgewertet.

thehos_740_3

Ich nutze die Funktion WENNNV, um #NV beim SVERWEIS zu vermeiden (seit Excel 2013) und WENNFEHLER, um generell Fehler abzufangen. Zum Beispiel, wenn die Felder leer sein sollten.

=WENNFEHLER(WENNNV(SVERWEIS($C3;INDIREKT("tab_"&$B3);2;FALSCH);"kein passender Eintrag");"")

Viel Spaß beim Nachbasteln
Andreas

Die Übungsdatei: Excel 740 SVERWEIS und INDIREKT

Hier geht’s zum Video:

Videolink zu YouTube: https://youtu.be/82FalCURBYk

Excel – Bereich für Datenüberprüfung mit INDEX identifizieren

INDEX ermittelt normalerweise einen Wert einer Matrix, der aus einer Spalte und einer Zeile identifiziert werden kann. Als Resultat von INDEX kann jedoch auch ein Bereich für die Datenüberprüfung genutzt werden.

So wird hier im Beispiel erst eine Sprache aus den Zellen D1:G1 ausgewählt und anschließend stehen die Werte der ausgewählten Sprache zur Auswahl zur Verfügung.

E384-1

Über Daten – Datenüberprüfung wird festgelegt, welche Werte zur Auswahl stehen sollen. Wichtig: Hier muss Liste ausgewählt werden.

Die Formel aus Zelle B1, welche in der Datenüberprüfung steckt.:

E384-2

Die Formel der Datenüberprüfung aus Zelle B2 lüftet das Geheimnis:

E384-3

Der Wert 0 an der Stelle, wo eigentlich die Zeilennummer stehen sollte führt dazu, dass alle Werte aller Zeilen der entsprechenden Spalte genommen werden.

Hier geht es zum Video: