Excel – Quersumme bilden

Bei der einfachen Quersumme q(123) wird die Summe jeder einzelnen Ziffer genommen. So resultiert hier der Wert 6 durch 1 + 2 + 3.

422a

Die Formel =SUMMENPRODUKT(1*TEIL(B1;ZEILE(INDIREKT("1:"&LÄNGE(B1)));1)) berechnet mit LÄNGE, wie viele Ziffern es gibt und rechnet über die Funktion TEIL die einzelnen Ziffern zusammen. Da die Formel im Array-Bereich von SUMMENPRODUKT geschrieben wird, kann die Matrixformelschreibweise mit geschweiften Klammern entfallen.

Die Multiplikation mit 1 ist notwendig, da sonst Textbestandteile addiert werden würden. Dies würde zu einer Fehlermeldung führen.

Alternativ hätte man auch jede resultierende Ziffer mit =SUMMENPRODUKT(WERT(TEIL(B1;ZEILE(INDIREKT("1:"&LÄNGE(B1)));1))) , also mit WERT von einem Text in eine Zahl wandeln können.

Ich danke an den jungen Fragesteller der mich zur Suche nach einer Lösung angestiftet hat. Bei meiner Lösungssuche bin ich auf identische Lösungswege bei Excelformeln.de gestoßen. Wer diese Seite noch nicht kennen sollte, dort werden die kompliziertesten Probleme und Fragestellungen mit eleganten Formeln gelöst. Auf Excelformeln.de werden in Beitrag 112 noch weitere Möglichkeiten zur Quersummenbildung – auch iterativ – gezeigt.

Hier gibt es die Übungsdatei:
E422_Quersumme