Excel – Dynamischen Bereich für Funktionen mit INDEX ermitteln

Aus einer Matrix heraus soll nicht eine Zelle über INDEX ermittelt werden, sondern ein ganzer Bereich. Diesen Bereich kann man natürlich auch mit BEREICH.VERSCHIEBEN identifizieren. Aber wie wäre es mit einem Spezialfall der INDEX-Funktion?

E385

=SUMME(INDEX(E2:H7;0;VERGLEICH(B1;E1:H1;0)))

Summe ermittelt die Summe über einen Bereich.
E2:H7 ist der Bereich der Matrix, der alle Werte beinhaltet.
Mit Vergleich wird der Wert B1 in den Überschriften oberhalb der Matrix gesucht. Ergebnis ist die Position, dies wird als Spaltennummer für die Matrix genutzt.
Mit dem Parameter 0 in INDEX wird gesagt, dass alle Werte aller Zeilen der gewünschten Spalte genommen werden sollen.

Übungsdatei zum Download:
E385_Index_Thehos

Hier geht es zum Video:

Ein Kommentar

  1. Andreas E

    Ist doch immer wieder interessant welche Möglichkeiten zur selben Lösung führen! War eine nette inspirierende Anregung Deine Datei …. 🙂 von =(SUMME(INDIREKT(ADRESSE(2;VERGLEICH(B1;E1:H1;FALSCH)+4)&“:“&ADRESSE(7;VERGLEICH(B1;E1:H1;FALSCH)+4)))) über =SUMME(INDIREKT(B1)) zu =SUMME(INDIREKT(Land)) 🙂 VG aus Lüneburg – Andreas