Excel 2013 – Tabellenblätter vergleichen – identische Formeln

Ausgehend von einem Master-Tabellenblatt werden jeden Monat Kopien dieses Tabellenblatts erstellt und mit Werten gefüllt. Die Tabellenblätter werden sich im Verlauf von einander unterscheiden. Doch muss auch darauf geachtet werden, dass die Formeln auf allen Blättern identisch sind. Es darf keine Formel verändert werden und nicht durch die Eingabe eines Zahlenwerts überschrieben werden.

E357-1

Normalerweise würde man solche Tabellenblätter schützen. Zellschutz für alle zu beschreibenden Zellen deaktivieren und dann einen kompletten Blattschutz, der gegen weitere Veränderungen der Blatt- und Formelstruktur schützt. Doch was, wenn die Blätter nicht geschützt werden (können)? Oder man sich die Blätter aus mehreren Arbeitsmappen zusammenkopieren muss?

E357-2

Folgende Formel kopiere ich in den Datenbereich A1:D9 eines Tabellenblattes. Hier stellvertretend die Formel für Zelle A1:

=WENN(ISTFORMEL(Original!A1);WENN(WENNNV(FORMELTEXT(Original!A1)=FORMELTEXT(INDIREKT($G$1&"!Z"&ZEILE()&"S"&SPALTE();FALSCH));FALSCH);"";"Z"&ZEILE()&"S"&SPALTE());"")

Die Formel prüft, ob in Zelle D1 des Tabellenblatts Original eine Formel steht. Falls ja, wird dieser Formeltext mit dem Text der entsprechenden Zelle eines anderen Blatts verglichen. Das Tabellenblatt soll aber variabel bleiben und wird hier in Zelle G18 z.B. über Datenüberprüfung angeboten.

E357-3

Da entweder eine Formel im anderen Blatt steht, oder eine Zahl, habe ich WENNNV gewählt. Die Funktion FORMELTEXT für eine Zelle mit reinem Zahleninhalt ergibt #NV. Im Falle, dass beim Vergleich mit einer falschen Formel oder einem Zahlenwert verglichen wird, wird die Koordinate dieser Zelle in R1C1-Schreibweise angeboten.
Sollte z.B. die Zelle D5 abweichen, liefert "Z"&ZEILE()&"S"&SPALTE()) das Ergebnis Z5S4.

Datei zum Download:
Blattvergleich

Zum YouTube-Video: