Excel – SUMMEWENNS in eine Array-Formel umwandeln

Die Bedingungen innerhalb der Funktion SUMMEWENNS müssen alle gleichzeitig gelten, ODER? Ein ODER ist eigentlich nicht vorgesehen, isn’t it? SUMMEWENNS kann in Kombination mit der Funktion SUMMENPRODUKT in eine Array-Formel umgewandelt werden, in der mehrere Szenarien geprüft werden.

538

Regulär müssen alle Bedingungen wahr sein und man könnte nur mit einem Wert eines Verkaufsberaters vergleichen – z.B. $H$2. Mit Summenprodukt können mehrere Werte verglichen werden, somit kann der Bereich $H$2:$H$5 nach auf Übereinstimmungen mit Spalte C verglichen werden.

=SUMMENPRODUKT(
SUMMEWENNS($D$3:$D$21;
$C$3:$C$21;$H$2:$H$5;
$B$3:$B$21;">="&F7;
$B$3:$B$21;"<="&G7)
)

Vielen Dank für diesen Tipp an Mike Girvin (aka ExcelIsFun). Er hat diesen Tipp auf YouTube in Folge 7 des Kanals „Excel TV“ demonstriert.

Hier ist die Übungsdatei:
http://1drv.ms/1jSpxXT

Hier geht es zum Video:

Videolink: http://youtu.be/TWC456NjO-A

Kurzlink zu diesem Beitrag: http://wp.me/p3egMz-uZ