Excel – Liegt eine sortierte Liste vor?

Ob eine Reihe Zahlen oder Buchstaben beinhaltet. Für manche Funktionen ist es wichtig zu prüfen, ob die Werte gleich oder zumindest aufsteigend sortiert sind.

Die Liste in Spalte A ist sortiert.

E362_1

Die Liste in Spalte A ist nicht sortiert.

E362_2

Die Formeln aus dem Video:
{=UND(A2:A14<=A3:A15)} von Dominik Petri

=SUMMENPRODUKT((A2:A10000<=A3:A10001)*(A3:A10001""))=(ANZAHL2(A:A)-2) erlaubt auch leere Zellen zum Schluss

=SUMMENPRODUKT((A2:INDEX(A:A;AGGREGAT(14;4;ZEILE(A:A)*(A:A"");1)-1;1)<=A3:INDEX(A:A;AGGREGAT(14;4;ZEILE(A:A)*(A:A"");1);1))*1)=(ANZAHL2(A:A)-2) ermittelt den tatsächlichen Bereich in Spalte A

Übungsdatei zum Download
E362_Liste_sortiert

Video bei YouTube: